Good Sound Maker ブログ

オーディオ・音楽制作・ライブ演奏用機器のレビューやお試しネタなどなど。

カテゴリ: トラブルシューティング

とりあえずメモです。

Windows10 anniversary update を適用してから、どうもUSBの調子が悪いので ViaのUSBドライバを入れ直してサインインしたら出たメッセージですが…

usb3Monitor
USB Monitor have already started!
usb3Monitor


なにかと思ったら、usb3Monitorというアプリが32bitのところと64bitのところそれぞれにあって、それぞれStartupに登録されているということらしいです。しかも32bitのところにあるのと64bitのところにあるのは同じ物でした。

ファイルがあるのはこの2つ。
c:\Program Files\VIA XHCI UASP Utility\usb3Monitor
c:\Program Files (x86)\VIA XHCI UASP Utility\usb3Monitor

レジストリのStartupにあるのはこの2つ。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\VIAxHCUtil
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run\VIAxHCUtil

…というわけで、どっちかのStartupを消せばよろしいようです。
タスクマネージャーを見ると、すでに起動しているのは前者の方なので、後者を消します。

コマンドラインから regedit を起動して、

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Run\VIAxHCUtil

 これを右クリックして「削除」

再起動。
解決^^v

レジストリをいじるときはバックアップして、くれぐれも慎重に^^!

(解決方法だけ見たい人は下の「解決方法」へ) 

MediaGoってアップデートするとCD取り込みの設定がリセットされたり、何らかトラブルがあるイメージですが…MediaGo3.1へのアップデートでもそれは起こりました…

MediaGo.exe システム エラー
「コンピューターにVCOMP140.DLLがないため、プログラムを開始できません。この問題を解決するには、プログラムを再インストールしてみてください。」

vcomp


うーん
これはもちろんMediaGoがきっかけで出ているエラーではあるのですが、Windowsのシステムが出しているエラーです。

「プログラムを再インストールしてみてください」
…とは書いてあるものの、これでうまく行くのはVCOMP140.DLLをMediaGoインストーラが正しくインストールしている場合だけです。今回はそれでは解決できませんでしたので、おそらく 本来であればMediaGoのインストーラーが配らないといけないWindowsの開発パッケージをMediaGoインストーラがインストールしていない、という問題だと思われます。

解決方法

1. マイクロソフトのサイトに行って、「日本語」「ダウンロード」を選択し、
https://www.microsoft.com/ja-jp/download/details.aspx?id=48145

2. 「Visual Studio 2015 の Visual C++ 再頒布可能パッケージ」をダウンロード&インストールします。
コレ→ vc_redist.x86.exe

3. MediaGoを再度起動します。

vc_redist.x64.exe というのもありますが、MediaGoが32bitアプリケーションなのでx86の方をインストールすればよいです。Windowsが32bitか64bitかは関係ありません。(心配ならvc_redist.x64.exe を同時にインストールしても問題はありません。将来64bitのアプリケーションがインストールされたときに同じ問題に遭遇しなくてすみます)

はい!直りましたかね??

なんでこういう問題が起こるかというと、開発者のPCにはこれがインストールされていることが多いから、気づかないんですね…ちゃんと検証してるのかな…

追記

以前のバージョンでは VCOMP140.dll ではなく VCOMP120.dll がないと言われることもあります。その場合は「Visual Studio 2015の再頒布パッケージ」ではなく「Visual Studio 2013の再頒布パッケージ」をどうぞ。MediaGoの開発環境が変わったのですな。
https://www.microsoft.com/ja-jp/download/details.aspx?id=40784


解決方法だけ知りたい場合、下の「解決方法」を見てください。

「ダウンロード待機中」地獄

大ベストセラーのパイオニア製カーナビ、AVIC-HRZ900 をいまだ利用し続けておりますが、地デジを見ていると毎度、勝手に「ダウンロード待機中」の表示になってテレビが中断してしまいます。ちょっと前まではこれ、何分かで終了していたのですが、最近なぜか失敗して終わる気配がありません。

調べてみると、これはチューナー上の情報を更新するためのもののようですが、こんなに頻繁にしなくても地デジ自体は見れるようです。そしてメニューに止める設定があるのですが、ググった結果を実践しようとしてもお目当てのメニューが 見つからないという人も多いと思います。とんでもないワナがありますから…

…ということで、ワナにかからないように順を追って説明します。

解決方法


(1)まずテレビ画面にします。
(2)次にテレビ画面をタップし、右上に「初期設定」メニューを表示させます。

これ、テレビ画面以外で「初期設定」メニューを開いてしまったらゲームオーバーです。
他から開いたメニューも「オーディオ設定」「システム設定」が並んでる全く同じメニュー画面に見えますが、別物です!!



(3)「初期設定」をタップします。(必ずテレビ画面から!)
32


(4)システム設定のタブをタップします。
39

(5)一番下の、「デジタルTV機能設定」をタップ(他の類似メニューからはココには来れませんよ~)

45


(6)「環境設定」タブから「ダウンロード設定」を見つける
52


(7)ダウンロード設定を「OFF」に!
56


テレビ画面では「初期設定」メニューは通常隠れているので、他の画面から初期設定メニューを開いてしまうと、 そっくりだけど「ダウンロード設定」の存在しない似て非なるメニューに連れて行かれてしまいます。

わかるかこんなもん!!
ま、でもiPhoneも流行る前の、古~いインターフェースですからね。しょうがない。大目に見ることにします。

お風呂スピーカーとして活躍中の UE MEGABOOM なんですが、最近電源を入れてもすぐに切れる現象に見舞われておりました。いつもじゃないんです。でも、電源を入れると「フーン」と効果音が鳴って、勝手に電源が切れるし、Bluetoothからの電源は、いつまでたっても電源ONになりません。

ということで、サポートに問い合わせて解決したのでご報告します。

電源ボタンとマイナス(-)ボタンを押したまま15秒でリセットです。

15秒たっても何も変化起きないので自分で数えます^^

Bluetoothのペアリングはやりなおしです。
UE BOOMやBOOM2は同じかどうか分かりませんが、もし同じ現象の方はお試しを!



Windows10にしてから、ZOOM UAC-8がたまに起動してこないことがありました。
電源は入っているのに再生デバイスに列挙されない、もちろん音も鳴らない…

DSC00751


これ、UAC-8の問題ではなくてマザーボードのUSB3に入ったMicrosoftのドライバとの相性問題のようでした。
確認方法は、音が鳴らなくなったときに

  1. ウィンドウズメニュー(スタートメニュー?)の右クリックから「デバイスマネージャー」を開く
  2. 表示メニューから「デバイス(接続別)」を選んで、
  3. ユニバーサル シリアル バス コントローラーの欄でマークがついているものがないか探す。(自分の場合はUSBルートハブ(xhci)という項目でした。詳細を見ると「USB ハブをリセットできませんでした。」という警告が出ていました)
  4. パソコン(もしくは自作の場合はマザーボード)のメーカーサイトでWindows10用のUSBドライバが出ていないか確認する。自分の場合はGIGABYTEのマザーボードなので、これでした(みんなそれぞれ違います、それぞれ自分のパソコン用を探す必要があります。お間違いなく!)

 GIGABYTE(GA-78LMT-USB3) 

 ここで USB3.0のドライバ(自分の場合は"VIA USB 3.0 Driver")が見つかったので、これを入れたら解決でした!デバイスマネージャーのUSB3関連のドライバは VIA USB 3 Root Hub などに変更されます。

PCの環境ごとに状況は違うのですが何かのヒントになれば幸いです。

 
ZOOM UAC-8
ZOOM UAC-8
(サウンドハウス)

このページのトップヘ